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1. Main Contents 
 Installer: this folder contains two executable files for Matlab Runtime environment installation. 

Users only need to run either one of these files: 

o “GlycoVis Installer_mcr.exe”: Installation does NOT require Internet connection 

o “GlycoVis Installer_web.exe”: Installation requires Internet connection 

 To be copied: this folder contains all the files needed to run the program. See the notes below 

for detailed explanation. 

 “Publication.pdf”: This file is the paper published by the authors describing the algorithm and 

main features of the program. Some examples were also included in the paper. 

 “GlycoVis Tutorial.pdf”: This tutorial file. 

2. Program Flowchart 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

3. Operating System Required 

Microsoft Windows XP, Microsoft Windows 7 

4. Programs Required 

 Microsoft Excel 
 Microsoft Internet Explorer, or Google Chrome, or Firefox 

5. Introduction 

GlycoVis is an automated visualization program to facilitate the visualization of metabolic 
networks.  It runs on Windows based machines, and has been tested on both Windows XP and 
Windows 7 operating systems.  An illustrative use of the program towards visualizing the protein 

1 2 3

g1 g2 g3 g4 g5 g6

g1 0 1 0 0 0 0

g2 0 0 1 1 0 0

g3 0 0 0 0 1 0

g4 0 0 0 0 1 0

g5 0 0 0 0 0 1

g6 0 0 0 0 0 0

51 2

3

4

…6

Metabolic Network

Experimentally 

Measured Glycan %

Relationship Matrix

GlycoVis

(glycovis.m)

Composite Network

Potential Reaction Pathways
Sequential Order of Enzymes

(relationshipmatrix.txt)

Glycan Data

(experimental   

data.txt)

Defined Glycans

(fullydefined.txt)

glycan

pathways3.txt

glycan

pathways6.txt

enzymelist2

.txt

enzymelist6

.txt

(compositenetwork.svg)

Simplified Network
(simplifiednetwork.svg)

gi % of total

1 0

2 0

3 20

4 0

5 0

6 80

gi fully defined

1 1

2 1

3 1

4 1

5 1

6 1

1 2 3 5 6

1 2 4 5 6ManI ManI ManI ManIManI ManI
51 2

3

4

…6

51 2 3 …6



2 

 

N-glycosylation pathway is shown below.  The program is adaptable towards other enzymes and 
systems. This version of the program takes into consideration 10 protein glycosylation enzymes. 
(See below) 
 
 
 
 
 
 

 

 

 

6. Relationship Matrix 

The enzymatic pathways were deduced using literature reported substrate specificities. There 
are multiple glycans that can potentially react with each enzyme, however not all of them do. The 
program assumes those reactions that are capable of occurring, to have an equal probability of 
doing so.  This criterion can be easily changed and implemented using the program’s relationship 
matrix as described below.  The current release of the program considers 341 distinct N-glycans.  
To transform the network of 341 N-glycans into a workable, mathematical formulation, a matrix 
was constructed to describe the glycan product-substrate relationships, and the corresponding 
enzymes that facilitate them.  This matrix is saved under the filename "relationshipmatrix.txt" in 
the “instructions” folder.  Each row in the matrix corresponds to a glycan reactant, and each 
column corresponds to a potential glycan product. Those reactant-product pairs that are allowed 
are given a non-zero value in the matrix corresponding to the numerical abbreviation of the 
enzyme responsible for their reaction, and those that are prohibited are given a zero value.  The 
relationship matrix can be readily modified to remove or include additional glycans, or glycan 
specificities.   GlycoVis can also be readily modified to have additional levels of glycan specificities.    

7. Glycan Data Entry 

In the attached “glycovisdataentry.xls” worksheet in the “instructions” folder, insert your 
glycoform profile data into the appropriate rows corresponding to the N-glycan measured.  For 
convenience, individual glycans can be found in the spreadsheet by filtering the glycans according 
to their sugar composition.  The auto-filter feature of Excel has been enabled in the spreadsheet so 
that you can specify the total number of each of the sugars that comprise the N-glycan.  An 
additional worksheet is provided in “glycovisdataentry.xls” that should be saved into a separate .txt 
file in the “instructions” folder. By default this file is “experimentaldata.txt”.  Typically, the exact 
sugar composition of the N-glycan is known, but the positional information of the terminal sugars 
on the glycan antennaes is not.  GlycoVis takes this into consideration by changing the shape of the 
nodes corresponding to these glycans.  By default, those glycans that are measured exactly are 
given an oval node shape, whereas those that are not are given a box shaped node.  You should 
specify in “glycovisdataentry.xls” whether or not each of the measured glycans were specifically 
measured.  An additional worksheet is provided that should be saved into a separate .txt file in the 
“instructions” folder.  By default this file is “fullydefined.txt”. 

 

Enzyme Name

Name Used In 

This Program

mannosyl-oligosaccharide 1,2-alpha-mannosidase Man I

mannosyl-oligosaccharide 1,3-1,6-alpha-mannosidase Man II

alpha-1,3-mannosyl-glycoprotein 2-beta-N-acetylglucosaminyltransferase GnT I

alpha-1,6-mannosyl-glycoprotein 2-beta-N-acetylglucosaminyltransferase GnT II

beta-1,4-mannosyl-glycoprotein 4-beta-N-acetylglucosaminyltransferase GnT III

alpha-1,3-mannosylglycoprotein 4-beta-N-acetylglucosaminyltransferase GnT IV

alpha-1,6-mannosyl-glycoprotein 6-beta-N-acetylglucosaminyltransferase GnT V

glycoprotein 6-alpha-L-fucosyltransferase FucT

beta-N-acetylglucosaminylglycopeptide beta-1,4-galactosyltransferase GalT

beta-galactoside alpha-2,3/6-sialyltransferase SiaT
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8. Potential Reaction Pathways and the Corresponding Enzymes 

GlycoVis calculates all the potential reaction paths traversed for the synthesis of each 
prominent glycan.  These potential reaction pathways are highlighted on a composite pathway 
map.  GlycoVis interfaces with GraphViz (http://www.graphviz.org) for the illustration of these 
pathways.  A copy of the appropriate Graphviz programs has already been included in GlycoVis.  In 
the illustration, nodes symbolically represent the glycans, and edges represent the enzymatic 
reactions. The nodes are colored according to their corresponding glycan percentage of the total 
glycoform profile, and the edges are highlighted with the same color as the nodes towards which 
they are directed to. If the same edge is used for pathways directed towards two distinct nodes, 
then the color corresponding to the higher percentage node is used. However, this default 
criterion for highlighting the nodes and edges can be easily changed.  The composite pathway map 
is constructed and saved in the folder "C:\glycovis\compositenetwork" in .svg format under the 
filename "compositenetwork.svg". The two "hot key" for .svg formatted files is CTRL. Holding down 
CTRL and scroll the mouse simultaneously allows one to create a zoom box that will bring various 
regions of the network into higher magnification. Mouse scrolling allows one to move the network 
around the screen space. The displayed composite network is a dynamic interface that allows you 
to zoom-in and click on the various nodes to see closer-up the glycan structures, and the pathways 
that traverse them. (See example below) 
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All potential reaction pathways from each experimentally measured glycan are saved into 
separate .txt files. By default, the filenames are “glycanpathwaysX.txt”, for prominent glycan X.  In 
addition, the enzymes responsible for the reactions in each pathway are also saved into separate 
.txt files.  By default, these filenames are “enzymesX.txt”, for prominent glycan X.  These files are 
tabbed-delimited files, and can be opened in Excel.  A representative screenshot is shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9. Simplified Reaction Path 

Having a concise image of the glycan biosynthetic pathways facilitates quicker physiological 
interpretation. Towards this end an additional simplified reaction path is shown 
("simplifiednetwork.svg") in the folder "C:\glycovis\simplifiednetwork" to more symbolically 
represent the potential pathways (see below).  In these illustrations, those reaction paths that are 
not utilized by the prominent glycans are removed, leaving only the highlighted edges, and nodes.  
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Again, the resulting pathway map is a dynamic interface with clickable nodes that open additional 
windows showing the glycans and the reactions that traverse them. 

10. Step-by-Step Instructions to Run GlycoVis:

Step 1: Install the Matlab Runtime environment for glycovis using either of these two methods: 
i. Execute the “GlycoVis Installer_mcr.exe” file. This method does NOT require Internet 

connection.
ii. Execute the “GlycoVis Installer_web.exe” file. This method requires Internet 

connection.
Step 2: Copy all the files and folders inside the “To be copied” zipped folder onto the 

“C:\glycovis\” folder. 
Step 3: Enter experimentally determined glycan data into  

"C:\glycovis\instructions\glycovisdataentry.xls" 
Step 4: Save data from the "Percentages" worksheet within "glycovisdataentry.xls" into the file 

"experimentaldata.txt" in the “instructions” folder. 
Step 5: Save data from the “Fully Defined” worksheet within “glycovisdataentry.xls” into the file    

“fullydefined.txt” in the “instructions” folder. 
Step 6: Run glycovis by double clicking on “glycovis.exe” in the “C:\glycovis\” folder. 
Step 7: The composite and simplified networks are returned back to the screen.  These files are   

also saved in the “compositenetwork” and “simplifiednetwork” folders. 

Note1:  
As a security precaution, your browser may “restrict” these files from opening automatically.  You 
may have to adjust browser settings to prevent “active content” from being blocked, or manually 
allowing it by clicking on the warning below the address toolbar. 
Note2: 
You may have to zoom-out on the compositepathway.svg and/or simplifiedpathway.svg files to fit the 
entire image on the screen  

11. Instructions on How to Modify GlycoVis to Include/Exclude Individual

Glycans/Reactions 

To introduce additional glycans into the program, one new row and column needs to be added 
to "relationshipmatrix.txt” for each glycan introduced.  All glycans that are capable of forming the 
new glycan(s) should be given a nonzero value into the array element(s) whose row(s) 
corresponding to the glycan substrates capable of performing the reaction, and the column(s) 
corresponding to the newly introduced glycan(s). All glycans that are capable of being formed 
from the new glycan(s) should be given a nonzero value into the array element(s) whose row 
corresponds to the newly introduced glycan(s) and whose column corresponds to the glycan(s) 
that are capable of being formed. To include additional reactions into the existing system, entries 
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with a zero value in "newrelationshipmatrix.txt" corresponding to the desired glycan reactant-
product pair should be changed to a nonzero value.  To exclude individual reactions in the existing 
system, entries with a nonzero value in "relationshipmatrix.txt" corresponding to the glycan 
reactant-product pair should be changed to a zero. 

12. Comments on GlycoVis

 You have the choice to visualize the individual N-glycans using the .gif files that incorporate
geometric symbols, or the chemical structures.  Both are provided in the glycovis package,
however by default, the geometric symbols are used for both the composite network and
simplified network.  If you want to use the chemical structures instead, you must copy those
figures from the “glycan figures with structural information” folder into the
“compositenetwork” and “simplifiednetwork” folders.

 Unless modified, the program was designed under the assumption that the input and output
files should be in the same folder (e.g “C:\glycovis\”).

 There are a large number of files created in the “simplifiednetwork” and
“compositenetwork”  folders. It is easiest to find the file of interest by using the View ->
Arrange Icons By ->Type feature in the menu bar

 The composite network images currently open into a larger window than necessary so as to
preclude resolution loss of these larger network images.  You must zoom out once the file is
opened to fit the entire network image on the screen.

 Longer computational times can be expected for mapping those glycans at the termini of the
biosynthetic pathway due to the larger number of potential pathways that can be traversed for
their synthesis.

 It is perhaps easiest to find the files of interest by not viewing hidden files.  You can accomplish
this by selecting “Do not show hidden files and folders” in Tools -> Folder Options -> View tab,
and setting “Do not show hidden files and folders”.

 GlycoVis formatted images can be edited outside the program by using other programs
released with Graphviz (see www.graphviz.org for additional information).

http://www.graphviz.org/

