A Simple Photogrammetry Rig for the Reliable Creation of 3D Artifact Models in
the Field: Lithic Examples from the Early Upper Paleolithic Sequence of Les
Cottés (France)

Instructions for automatically masking a black background in Agisoft PhotoScan

This document provides step-by-step instructions on how to easily mask sets of images taken
with a black background for the purpose of creating 3D models in Agisoft PhotoScan. This
tutorial does not aim to be comprehensive or definitive. Rather it is meant to be used as a guide
for beginners. The authors encourage readers to seek out additional resources to learn about
additional masking options.

Method 1 uses background masking capabilities within Agisoft Photoscan itself. Method 2
creates alpha channels using Adobe Photoshop. This second method allows users somewhat
more control of the exact extent of the generated image masks. Users may wish to try this
second method if the application of the first method does not result in a mask with a clean edge
around the target object.
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The following versions of the software listed below were utilized in creating these tutorials:

Adobe Photoshop CS6 Version 13.0.1 x64
Agisoft PhotoScan Professional Edition Version 1.1.5 build 2034 (64 bit)
Microsoft Paint Windows 8.1 Edition Version 6.3 Build 9600



Step 1 — Option 1 Creating a black ‘background’ image in Adobe Photoshop

1. Open Adobe Photoshop. Click File > Open.
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2. Navigate to the set of images you want to process. Select one of the images and click Open.
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3. Click Select = All.
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5. Set the contents to use Black. Click OK.
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7. Choose a place to save this background image. Navigate to this folder. Set the file name as
something easy to remember like “background.” Save the file as a JPEG.
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8. If prompted, at this step you may accept the default settings that Photoshop provides.
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Step 1 — Option 2 Creating a black ‘background’ image in Microsoft Paint

1. Open Microsoft Paint. Click File > Open.
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3. The image may open at full size, and so only a portion of the image may be visible. Click
View > Zoom Out until the entire image is visible. Alternatively, you may use the slider bar
in the lower right hand corner.
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4. Return to the Home tab. Make sure that both Color 1 and Color 2 are set to black.
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5. Click on the rectangular shape icon. Click Fill and set it to Solid Color.
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6. Drag a rectangle across the image. This should turn the entire image black. Reposition /
resize the rectangle, or repeat the previous stage if necessary.
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7. Click File > Save As - JPEG picture.
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8. Choose a place to save this background image. Navigate to this folder. Set the file name as
something easy to remember like “background.” Save the file as a JPEG. Navigate to this
folder. Set the file name as something easy to remember like “background.” Save the file as
a JPEG.

IMG_5182 - Paint S = |
Y
= . g ENEEN EEEN [ |
Color | Color . . Eddt
1 2 colors
¥ UMN_RUN * Y4-284-Originals [+
Organize = New folder = = 17}
A This PC ) "
Iy Desktop »
Documents = s
s Downloads IMG_5182 IMG_5183 IMG_5184 IMG_5185 IMG_5186
b Music
E Pictures g
B Videos < —
& Windows (C) IMG_5187 IMG_5188 IMG_5189 IMG_5150 IMG_5191
& My Passport (D)
WS - - - -
File name§ background 5
Save as ype JPEG (*jpg;*Jpeg jpefil) g
= Hide Folders Save Cancel
121 4000 = 2936px = Size: 20M8 125% (= &



Step 2 Importing photos and masks into Agisoft PhotoScan

1. Open Agisoft PhotoScan. Click Workflow - Add Folder.
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3. If prompted, select Create camera from each file. Click OK.
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4. Once the images are imported, click Tools - Import > Masks.
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5. For the masking method, select From Background. In this case, we are using a single file to

mask

all of the images. Set the file name to be one you created in Step 1. You can also

change the level of tolerance' the masks will be processed with. In this case, we want this to
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6. Navigate to the folder where you saved the background image, then click OK.
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7. PhotoScan will now begin creating the image masks.
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Once processing has completed you can preview the masks by toggling the icon circled in
red below. You can view masks in greater detail in the center window by double clicking on
the thumbnails in the Photos pane (displayed here on the right). You can also edit individual

masks once they are imported into PhotoScan by using the tools circled below in blue. Once

you are happy with your masks, you can proceed with processing your 2D images into 3D

models.
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Method 2

Step 1: Creating an action in Adobe Photoshop

1) Open a photo taken with the photogrammetry rig in Adobe Photoshop.
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3) Create a new action by clicking on the H icon (circled in red in the screenshot below). Give the
new action a name, and set it as a default action. Click Record.

PS File Edit Image Layer Type Select Filter View Window Help
* - 0@ F G s i e ¢ Tolerance: ¥ Ant-alias Contiguous Sample All Layers Refine Ed

IMG_0977.JPG @ 22.7% (RGB/8) *

Actions
B v & DefaultActions
=] Wignette (selection)
=] Frame Channel - 50 pixel
Wood Frame - 50 pixel
Cast Shadow (type)
Water Reflection (typs)
Custom RGE to Grayscale
Vialten Lead
Wiake Clip Path (selection)
Sepia Toning (layer)
Quadrant Calars.
Save as Photoshop PDF
[
Wiixer Brush Cloning Paint Setup
Deshadow_PDF
Wiask ong
i to JPEG
Auitocolor

Sharpen

O O S O S U

reduce siz=

Name: | i Record |

et: Cancel

PENTHR AR NENS W XD

Function Key: | Hone v

il
s

Color: | x None

Doc: 34.3M/243M

A red circle will appear showing your actions are being recorded.
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4) Using the magic wand tool select a spot on the black background in the upper left hand
corner of the image (represented below by the red X). You will want to click on a place that will
consistantly select the background in each photo, you are processing and not the object. Make sure
the box next to Contiguous is checked (as indicated by the white arrow). You may want to
experiment with the tolerence level, but a setting of 15 usually works well.
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5) Change the selection to the object and scale rather than the background by clicking Select >
Inverse.
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If you zoom in, you will likely notice a line of black pixels is still included in your selection.
mitigate this, click Select = Modify = Contract.
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Contract the selection by 2 or 3 pixels, depending on the resolution of your photos and the size of the
remaining black area you observe. Click OK.
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The selection should now be tighter around the edges of the target object.
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7) Now you will create an alpha channel around representing your selection. To
Save Selection.
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Save the selection as a new channel. Give the channel a name. Click OK.
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You can use compression in order to avoid overly large file sizes. Click OK to save the file.
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% IMG_0977-Recovered.JPG @ 24.6% (RGB/8) * x

Actions

v &= Defaulkt Actons

b 4

Channels
Frame Chans

Wood Frame - 50 pixel
CastShadow (type]
Water Reflection {type]

Bachground

Cancel Custom RGB to Grayscale

Molten Lead
Make Gip Path (selection
Sepia Toning (layer
Quadrant Cokors

Save as Phatoshop PDF
Gradiant Map

Micer Brush laning Pai...
Deshadow PDF
mask_org

TH 0 JPEG

Autocolor

Sharpen

4 ¥ ¥ ¥ ¥ ¥YY¥YYTYIYTYTTrTrryyvrvrryy

Photogrammetry_Mask

Contract

Duplicate Selection

10) Stop recording the action by clicking the square stop icon - on the actions window (circled in

red below).

Image Layer Type Select Filter View Window Help
Resize Windows to Fit Zoom All Windows ¥ Scrubby Zoom Actual Pixels Fit Screen Fill Screen Print Sze
x  IMG_0977-Recovered.)PG @ 24.6% (RGB/8) * >

Actions

¥ &= Default Ackons

v

Channels
Frame Channel - 50 pixcel

Wood Frame - 50 pixel
Cast Shadaw (type
Water Refiecton (type)

Background

Custom RGB o Grayscale
Wiglten Lead

Wiake Clip Path (selection)
Sepia Taning (layer
Quadrant Cokors

Save as Photoshop PDF
[

Witcer Brush Cloning Pai...
Deshadow_PDF
wiask_orig

TH o JPEG

Autocolor

Sharpen

reduce =

4 ¥ ¥ ¥ ¥¥YY¥YTYYYTYYIYTYTYTrTrryyyvwy

Photogrammeiry_Mask

b Contract
b Duplicate Selection
> Sae
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Step 2 : Running a Batch Process

1) Create folders for your raw and processed photos.

Share View

v Demo » Photos & Search Photos

~ [ Name Date modified Type Size

0 Favorites
B Desktop Processed 12/7/2014 612 PM  File folder
#& SkyDrive Raw 2/7/2014 612 PM File folder

& Downloads
%3 Dropbox

5| Recent places

¢@ OneDrive
Documents
. Pictures
. Public

!@ Homegroup

This PC

m Desktop

‘| Documents
& Downloads
W Music

=| Pictures

B Videos

2 items

2) In Photoshop click File = Automate - Batch.

File Edit y y
New.. Ctil+N
Open... -0
Browse in Bridge... LS e PRV I =d. PG @ 24.6% (RS
Browse in Mini Bridge.
Open As... Alt+Shift Ctrl+ O
Open as Smart Object.

Open Recent
Channels.

Close Ctrl+W
Close All Alt+Ctrl+W
Close and Go te Bridge. Shift+Ctrl+W
Save Ctrl+S
Save As... Shift+Ctrl+S
Check In...

Save for Web... Alt+Shift+Ctrl+ 5
Revert F12

Place...

Import
Export

Seripts PDF Presentation..
Create Droplet.

File Info Alt+Shift+ Ctrl+]

Print... cutep | Crop and Straighten Photos

Print One Copy Alt+Shift+Ctrl+P Contact Sheet Il...

Ctl+@ | Conditional Mode Change...
Fit Image...
Lens Correction...
Merge to HDR Pro...
Photomerge...
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3) Select the action you created in the previous step. Set your source folder as the folder containing
your raw images. Choose your desired destination folder for your processed images. Make sure
that Override Action “Save As” Commands is selected (as indicated by the red arrow below). Click
OK.

play
Set:| Default Actions

Action: | Photogrammetry_Mask

Source:  Folder v

Choose... | C:\Users\Samantha\Desktop\Demo\Rawd,
[]override Action "Open” Commands
[Jinclude All Subfolders
[[]Suppress File Open Options Dialogs
] Suppress Color Profile Warnings

Destination: | Folder v

Choose... | Ci\Users\Samantha'Desktop\Demo\Processed)

eride Action "Save As” Commands
File Naming
Example: MyFie.gif

Document Name v| + | extension

7
o
L
=
&
é
A
[}
r'a
T

v+

2

v| +
Starting Serial #: | 1
Compatbilty: (¥ Windows []Mac 0S []Unix

P&

[
+

Errors: | Stop for Errors v

4) Once the batch process has run, if you open the designated destination folder for your processed
images, the image thumbnails should display with a white background.

. | &M= Picture Toals Processec I X

File Home  Share  View Manage v 0
© ~ b » Demo b Processed v & | | SearchProcessed 0
-~ L)
0 Favorites
B Desktop
& SkyDrive

i Downloads IMG_0977 IMG_0978 IMG_0979 IMG_0980 IMG_0%81 IMG_0982

Eo Dropbox

15| Recent places I ! ! ! ! l
& OneDrive v “

DicinE 1MG_0983 IMG_0984 IMG_0985 IMG_0986 IMG_0987 1MG_0988

. Pictures

Public I . . l I l

Y Homegroup IMG_0989 IMG_0990 IMG_0g91 IMG_0992 IMG_0893 IMG_0994
1% This PC

m Desktop ) .

| Documents

i Downloads 1MG_0995 IMG_0996 IMG_0997 IMG_0988 IMG_0998 IMG_1000

ol Music

A N B A U Ny QN

89 tems 1 item selected B.42 MB B (= 23




Method 2

Step 3 : Importing Image Masks into Agisoft PhotoScan.

1) Import your photos into PhotoScan by clicking Workflow = Add Photos. Select the appropriate

folder.
Fie Edt View | Worllow | Tock Photo Help
0= 6 [G] 8 addPhotes.. Ao EEe s s @l
Werkspace |4 Add Felder... ] 8 % protos 8%
B8 997  asgnrhotes. eexXx A MEE-
% Worspace (Deh  Buikd Dense Cloud..
Buikd Terture...
Algn Chuniks.
Merge Chunks_
Model E3

Lead addaicnal photos from felders

2) Once the images are imported, you can import the masks. Do this by clicking Tools = Import 2>
Import Masks.

File Edt View Wordlow | Tools | Photo  Help
DERESOQ] M rEe oo s [@s
Dhervse Clowd *

& X Phots L
A — | | ooxacmom |
Wodkspace (1 chunks, S con  frpont » Impont Texture_. n
o [ Chumk 1089 cameras) — import Camerss.
. :i S | import Masks...
1MG_0aT7.if G 09T
IMG_0979.if 184G 0RO
1MG_0381.tif 4G 05824

IMG_0985it MG D54

1MG_0985 8 IMG_0586.64
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Import masks for the entire workspace. The method should be set to From Alpha. Click OK.

Untitled* — Agisoft PhotoScan

Import Mask

Parameters

Import masks for: | Entire workspace

Method: From Alpha
Mask fle names:  {fiename)_mask.pg
Tolerance:

OK Cancel

8 x| photos 8 x
x
IMG_0977.tif IMG_0978.tiF

y

IMG_0979 tif IMG_0980.tif

/ 5

IMG_0381 tif IMG_0982.tif

IMG_0383 tif IMG_0984.tif

& o
T

IMG_0985.tif IMG_0986.tif

=
Far

Once the masks are imported, you can view and edit them by double-clicking on images in the photo

H
CER GOS8 X T 28
Workspace
2 B X
Workspace (1 chunks, 89 cameras)
Chunk 1 (89 cameras)
Model [£]
Perspective
=
=
File Edit View Workflow Tools Photo Help
H } N R
Workspace
29X
Workspace (1 chunks, B3 cameras)
Chunk 1 (89 cameras)
Model mG_oa7e.4f B3

Untitied* — Agisoft PhotoScan

& X Photos & x

209 X 2t -

I tif

IMG_0978.tif

IMG_0979.tif IMG_D380.1if
-
IMG_0981.if IMG_0982.tif
\ “ 7
IMG_0983.if IMIG_0984.tif
-

;4
1MG_D385 i IMG_D926.tif

mm
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